Week 7, Chapter 6 Notes

in Spring 2007). Beginning Fall 2007, the SRJC Photoshop
certificate will require all five classes (17 units)

via the nimble fingers of Nancy Carroll, edited by Barbara
Heiman

There are also 2 8 week Web Graphics classes that will be
offered again Fall 2007. HTML 1 is a prerequisite.

We miss you Rick, so we will postpone the cheese until next
week when you are here, 11:30 am in the Quad on October 12.

CIS 58.53A Web Graphics Projects

Assignment clarification (Barb): see the Assignment page on the
class site—clarified there.

Today’s look at web graphics
Animated gifs...”like changing your oil filter with tweezers”
Flash is really the right product for big animation
ImageReady Animations are okay for little some things that
moves on your website, otherwise use Flash...vector based will
be smaller file
The animated gif we did last week was fun but in real life, keep
colors as limited as you can to minimize file size.

CIS Photoshop and related courses
now and in Fall 2007
Class #1 is 73.21 Intro

CIS 58.53B Adv. Web Graphics
Question on Upgrades to new version, whenever it comes out.
(Adobe says some time in spring of 2007.) Barbara wasn’t sure...
maybe most economical is to get education version on Suite
compared to Upgrade from education to full.
Week 7 class files are on Petchaos’(M)...CIS...CIS 73.23...
Student_Files_3...Week 7..bring over whole Week 7 folder(Copy)
to Thawspace Paste)..5 files in the folder…
Open PS...(vs...ImageReady). Chap 6 CD Notes you will see the
differences. We can build an Image Map and Build Rollovers.

Strategy for building web files with
remote rollovers and/or image maps
1. Start in PS to create files because PS has the basics, more
editing tools.

Class #2 is 73.22 Intermediate

2. Create all of the layers and layer sets for the different states
you will need, and save your document in PSD format.

Class #3 is 73.23 “Advanced” Concepts
THESE FIRST THREE COURSES GIVE YOU THE CURRENT CIS
MASTERY CERTIFICATE IN PHOTOSHOP

3. Jump to ImageReady to finalize the web-specific parts of
your files.

Class #4 is 73.24 Restoration/Photo Correction (aka Fixing
Images with Photoshop)

4. In ImageReady, slice your PSD file if necessary, optimize the
slices for the Web, and make your JavaScript rollovers and
image maps.

Class #5 is 73.25 Projects (developing your web and print
portfolio) is a new course that will be taught for the first time
next fall, using Photoshop CS3 (to be released some time

5. File > Save to update the source PSD file once you have
made the web enhancements. (You cannot be in Preview
mode to do this.)

Chapter 6: ImageReady

Page 81

6. Save Optimized As in a new folder to hold the HTML, Image
folder, and other associated Web files that ImageReady
creates.
7.

If you do not have your own web site, you will zip this folder
and upload it to the correct assignment inbox to submit your
work.

How to Make the Mickey Mouse Remote
Rollover
Barb stepping in here: Follow these steps to follow to turn the
Fireworks image we worked with last week into an animated
GIF with remote rollover. It is not quite what I did in class, but
should be easier to follow.
1. In Photoshop, open Fireworks.psd. If the font is missing
(Photoshop will warn you), change the font of the type layer
to one you like.
2. Duplicate the image and save the duplicate. In class, I
named it Fireworks_rollover.psd.
3. To conserve RAM, close the source file (with or without
saving; it’s up to you).
4. Choose Image > Image Size to
check the file size. 1339 x 1674,
has way too many pixels to view in
a web browser without scrolling.
5. With Resampling checked, reduce
the vertical size of the image to
500 pixels. Its width will change
to 400 pixels with Constrain
Proportions checked. Now it will fit
in a web browser without scrolling.
(In class we tried 600 pixels
first, but it didn’t fit.) We used
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Interpolate: Bicubic Sharper. You can pick the interpolation
method you like best.
6. Double click the Zoom tool to bring to 100% view.
7.

Add a layer style to the type layer (Ooh! Aah!) to change
its appearance. For example, bevel and emboss it, and add
a color overlay. This will be your mouse-over state for the
type.

8. Turn off the layer style visibility from the Layers palette (you
don’t want to see the layer style in the initial view.
9. Open Mickey2.gif. (It’s in the week07 folder in the lab.)
10. Choose Image > Mode RGB to change the mode of Mickey2.
gif from Indexed Color to RGB. (You typically can’t combine
images with different image modes.)
11. With the Move tool, drag Mickey onto the Fireworks image,
and place him just above the type in the right corner of the
image.
12. Close Mickey2.gif without saving.
13. Name the new layer Mickey, add a layer style to it that
makes Mickey just an outline, and also reduce the layer
opacity so that he is much less noticeable. (I used a gray
color overlay with a bevel and emboss effect, and reduced
opacity to around 40%). Leave this effect visible, because it
will be your starting state.
14. Save the document, and jump to ImageReady using the
button at the bottom of the toolbar. You can now toggle
between PS & ImageReady.. seeing your file in each one.
End up in ImageReady.
15. Choose Window > Workspace > Default Palette Locations
to see Palettes available in ImageReady. ...full slice palette
available, also Image Map and Table palettes, a new palette
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called Web Content, next to Color Table; Layers, History,
Actions together..
16. Zoom out so that you can see some of the document
window beyond the image itself. To Zoom out, choose Cmd/
Ctl (–)...since there is no Navigation Palette in ImageReady.
Cmd/Ctl (+) Zooms in. These also work in Photoshop.
17. Choose the Slice tool. Image Ready separates the Slice and
Slice Select tools, be sure to pick the Slice tool on the left
side.
18. Drag diagonally from below the right side of the document
to the left to make a slice that just includes the type, and
release the mouse. You now have 2 slices: the lower User
Defined slice and the upper Automatic slice.
19. With the Slice tool, make one more slice that
begins just above and to the left of Mickey,
and drag down and right to make a slice that
includes Mickey and ends up at the edge of your
first user defined slice. ImageReady will make
another Automatic slice to the left of the Mickey
slice, so your document should now have 4
slices total. If you have more, you didn’t get the
slices in the correct locations. Choose Slices >
Delete All to get rid of slices to start over.
20. Look at the Web Content palette. It has two
generically named used-defined slices. Click
on the one that contains the type, activate the
Slices palette, and rename the slice “type.”
21. Back in the Web Content palette, click the slice that contains
Mickey, go back to the Slices palette, and rename that slice
Mickey. Notice that you can now use the Web content palette
to select either one of your user defined slices. Using this
technique instead of the Slice Select tool avoids accidentally
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moving a slice as you select it. If you move a slice, you can
end up with unwanted extra automatic slices.
22. In the Web Content palette, activate the Type slice.
23. Click the Create Rollover State button at the bottom of the
palette. Now you have a (mouse) over state, but it is exactly
the same as the original. Be sure the Over state is active in
the Web Content Palette.
24. In the Layers palette, turn on the visibility of the “Ooh!
Aah!” layer style and turn off the visibility of the Mickey
layer style and restore its visibility to 100% so that you see
Mickey. (Mickey may or may not display these settings in the
document window, but don’t worry, we’ll fix that soon.
25. This is a good time to update the saved file by
choosing File > Save or Command/Ctrl + S.
26. Click the toggle Slice Visibility to hide the slices,
and click the Preview Document button to try out
your remote rollover as it will appear on the Web.
(These buttons are just below the Foreground/
Background swatches.) Notice that when your mouse
is over the type, it changes color, but Mickey does not
change. The rollover is working, but not the remote
part.
27. Turn off the Preview Document button so that
you can continue to edit your document. With the
Over state active in the Web Content palette, choose
Find Remote Slices for State from the palette menu,
and click OK when a dialog box appears. This step
links any remote slices to the active one.
28. Preview again to be sure your remote rollover now works.
29. Optimize the slices as shown here.
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30. Save the document.

Mickey slice settings

31. Make a new folder where you want the web files to appear,
choose Save Optimized As, and save the HTML and image
files to that location. Here are the settings I used:
Type slice settings

The two automatic slices were selected and optimized as
medium JPGs.

The rest of Nancy’s notes:
Save it since it is break time.......
Boy this is very difficult taking notes...my wrists are getting
sore....
Over break I saw a variety of things…
ImageReady..File>Save..only have Save Optimized and Save
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Optimized As..need to toggle out of Preview mode to get back to
full range of save options..save as…

Colors: 32
Or change to Jpeg instead

Next: if you made your original slice(user defined slice) at the
top…here’s how to change it…make both slice into User Defined
Slices..you’ll see in the Web Content Palette both these slices…
then you can toggle betw the 2 slice to make one or the other

Chg Alt to: fireworks

Activate Automatic Slice>Slice>Promote to User Slice

Want to see how it looks on web, diff browsers…

Control our slices (turn off preview), go thru to set document up
for the web…

Button that looks like Internet Explorer will bring it up for you to
test if it works. Button is on the lower part of the tool bar.

In ImageReady, make slices, regular state, rollover state…
prepare for the web…

Saving:

Quality: Medium
Back to Slice Palette

Use Optimize Palette and the Slice Palette:

Give ImageReady a folder for everything to go in: Barbara used:
hidden_mickeys

Slice Select Tool: Gif format..Optimize: Gif 32 no dither, Color: 16

Save as type: HTML and images

Go to site: http://www.hiddenmickeys.org so the next time you
go to D you will know where he’s hiding…

Inside this folder will be the HTML file and the Images FOLDER

Type: Image
Name: the Slice OOH AAH (in the Slice Palette)
URL: http://www.hiddenmickeys.org
Target: _blank
Alt: ooh aah (HTML,web standards, decent code)Alt Tag is what
shows up on the page when your curser crosses the image.
Slice for Fireworks
Name: fireworksrollover_03
Alt: Mickey Mouse
Optimize Palette.
Format: Gif
Selective
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Windows folks: Don’t use PK Zip to prepare your files because it
doesn’t include folders without special configurations. XP has a
built-in zip utility…rt ck..Send to…compress folder
Mac folks: Right or ctrl+click the source folder and choose
Create Archive of… to make a zip file.
Go to Slices (with in file with type, mickey just above type)
Delete All (slices)
Make Slices (window not maximized, must have some gray space
around image)
With slice tool 1) slice type from bottom rt corner to left
above type 2) from rt bottom just below Mickey, slice upward
toward left top corner of Mickey (have 2 user defined slices
and 2 automatic slices – can only use Web Content Palette.
On User Defined Slices) Web Content Palette: acive is the
fireworksrollover_3 (for the Mickey layer/slice) Make sure you
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can see the effects list on the Mickey Layer on layer palette.

how helpful Alt Tags are to the viewer.

You should have Active the “fireworksrollover_3 in the Web
Content Palette AND the Mickey layer in the Layers Palette.:

Back to work at hand: Guided Exercise 6.1 on page 77 of CD
Notes

In the Web Content Palette. Click the “Create Rollover State”
button at the bottom of the palette, next to trash can. This gives
you a second state in that palette named: OVER

Get to chapter 6 files. Rt clk or ctrl clk to copy file and take it
back to thawspace: map_start.jpg

Go back to layers palette. And turn OFF the “effects” eyeball to
reveal the colorful Mickey.
Now you can toggle between orig. Mickey and the effects Mickey
by clicking the 2 diff. bars in the Web Content Palette.
Let’s do the same steps for the OOH AAH slice by repeating
these steps, making sure you are ACTIVE on the Ooh Aah slice
in the Web Content Palette and the Text layer in the Layers
palette with the effects OFF to start.

we are in ImageReady
use Rectangular(also Circle and Polygon) Image Map Tool (under
slice tool) to select upper rt tile (and each successive part of
image) and give it a URL using the Image Map Palette. Target :if
you choose _blank then the url will open as its own window.
Keep doing this process to give URL to different spots in the
image.

create rollover state and turn the effects ON
Homework:
Check the class Assignments sheet for most current version on
this week’s assignments.
Next week a 8 wk review – no new material at the end of
the week take an online test from the test bank to total 30
questions. Use forum to start review online, let Barbara know
what we want reviewed next week in class. Online class has
been invited to attend if they wish.
See forum for corrected notes for rollover in Chap 6.
Rick, you know we didn’t get cheese today because you weren’t
here. Boy am I hungry…
Looking at Donald Laird’s website: http://www.donaldlaird.com/
landmarks/ scroll down for the state of CA with the counties, no
alt tags but at the bottom you see co. name, etc. This shows
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